Travis builds for SFML 2 projects

Configuration file for Travis builds

Travis YAML file

Travis for today (2014-12-01) provides only Ubuntu Precise based environments, which, unfortunately come with sfml in version 1.6.  There are few approaches to solved this problem, in my case I have decided to use binary version of library available from the project site:

language: cpp
compiler:
  - gcc

before_script:
  - wget http://sfml-dev.org/download/sfml/2.1/SFML-2.1-linux-gcc-64bits.tar.bz2 -O /tmp/sfml.tar.bz2
  - tar -xjvf /tmp/sfml.tar.bz2
  - sudo cp -r SFML-2.1/* /usr/
  - sudo apt-get install -y libjpeg62-dev libsndfile1-dev libglew1.5 libglew1.5-dev libfreetype6 libjpeg-turbo8 libjpeg8 libopenal-data libopenal1  libxrandr2 libxrender1 libsoil1

script: make